Podium - New Payment requests skipping service charges – Incident details

All systems operational

New Payment requests skipping service charges

Resolved
Degraded performance
Started 12 days agoLasted 18 minutes

Affected

Payments

Degraded performance from 2:36 PM to 2:54 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified
    We are experiencing an issue where newly created invoices are failing to apply service charges that are setup in the Podium Payments Settings. We have Identified the issue and working on a fix!