Podium - Payments Card readers not responding – Incident details

All systems operational

Payments Card readers not responding

Resolved
Degraded performance
Started 6 days agoLasted about 6 hours

Affected

Payments

Partial outage from 2:02 PM to 7:59 PM

Updates
  • Resolved
    Resolved

    This incident is resolved, please refresh the Podium Webpage before processing a payment on a card reader.

  • Update
    Update

    We are actively investigating the issue with the card readers. If experiencing errors, please process the payment on a different transaction method like Text-to-pay or Manual Entry.

  • Investigating
    Investigating

    We have gotten reports of card readers not responding and we are investigating the issue.