Resolved
Next-Day Payout Delays

Started
December 20, 2021 at 5:52 PM
Status
Resolved after 2 days
Affected
Payments

Impact

Operational
  • Resolved
    December 22, 2021 at 7:03 PM

    Next-day payouts should be returned to their normal schedule. We appreciate your continued support.

  • Monitoring
    December 20, 2021 at 5:52 PM

    Some merchants on next-day payouts may experience a delay on their payouts for transactions made on Friday, December 17, 2021. These payouts will be delayed until Tuesday, December 21, 2021. Next-day payouts are expected to return to normal starting Tuesday, December 21, 2021. We apologize for any inconvenience and appreciate your continued support.