Resolved
Mobile Reader Connectivity

Started
February 18, 2022 at 8:33 PM
Status
Resolved after about 2 hours
Affected
Payments

Impact

Operational
  • Resolved
    February 18, 2022 at 10:39 PM

    The mobile Card Reader connectivity issue has been resolved with a new mobile app update on Android and iOS. Please update to version 7.5.81 for these new updates. We appreciate your patience

  • Investigating
    February 18, 2022 at 8:33 PM

    We are aware of an issue preventing some businesses from connecting to their mobile card readers and accepting payments. We are investigating the cause and will provide an update as soon as possible. Text-to-pay, manual card input, and stationary card readers are unaffected and fully functional.