Resolved
Users might see issues with completing payments

Started
April 29, 2022 at 9:02 PM
Status
Resolved after less than a minute
Affected
Payments

Impact

Operational
  • Investigating
    April 29, 2022 at 9:02 PM

    Starting around 2:47pm MDT, our payment processing is currently seeing elevated errors. We will provide updates once the issue has been identified. We apologize for the inconvenience.

  • Resolved
    April 29, 2022 at 9:02 PM

    Starting around 2:47pm MDT, our payment processing is currently seeing elevated errors. We will provide updates once the issue has been identified. We apologize for the inconvenience.