Resolved
Payment functionality is down

Started
June 13, 2022 at 5:15 PM
Status
Resolved after 27 minutes
Affected
Payments

Impact

Operational
  • Resolved
    June 13, 2022 at 5:42 PM

    The issue should be resolved. We're working to ensure a similar incident is prevented in the future. We appreciate your patience

  • Identified
    June 13, 2022 at 5:36 PM

    We believe we have identified the issue and are working on a fix.

  • Investigating
    June 13, 2022 at 5:15 PM

    We are currently investigating this incident. We will post an update soon on what is affected.