Resolved
Voice Inbound/Outbound calls failing

Started
June 20, 2022 at 3:27 PM
Status
Resolved after 6 minutes
Affected
Voice

Impact

Operational
  • Resolved
    June 20, 2022 at 3:33 PM

    This issue has been identified and resolved. Thank you for your patience.

  • Investigating
    June 20, 2022 at 3:27 PM

    Podium has identified that around 8:40MST, the Voice product started experiencing issues with inbound and outbound calls. We are investigating this incident and will provide an update as soon as one is available.