All systems operational

Unable to log into the platform

Resolved
Operational
Started over 1 year ago Lasted 6 minutes

Affected

Web Application
Updates
  • Resolved
    Resolved

    This issue should be resolved! We appreciate your patience

  • Investigating
    Investigating

    We are currently investigating an incident where some users are unable to log into Podium. Our team is all hands on deck to fix this issue. We will provide an update soon.