Podium - Podium is currently experiencing issues – Incident details

Reviews experiencing degraded performance

Podium is currently experiencing issues

Resolved
Operational
Started over 2 years agoLasted 25 minutes

Affected

Payments

Operational from 11:11 PM to 11:36 PM

Updates
  • Resolved
    Resolved

    We have resolved this issue. Behavior should return to normal

  • Investigating
    Investigating

    We are currently seeing issues across Podium. Payments is largely affected although other areas could also be affected. We're actively investigating the scope and cause of these issues.