All systems operational

Scheduled Maintenance

Completed
Scheduled for October 22, 2022 at 4:00 AM – 4:30 AM

Affected

Reviews
Updates
  • Completed
    October 22, 2022 at 4:30 AM
    Completed
    October 22, 2022 at 4:30 AM

    Maintenance has completed successfully

  • In progress
    October 22, 2022 at 4:00 AM
    In progress
    October 22, 2022 at 4:00 AM

    Maintenance is now in progress

  • Planned
    October 22, 2022 at 4:00 AM
    Planned
    October 22, 2022 at 4:00 AM

    There will be maintenance on our Reviews platform tonight, October 21st, from 10:00pm to 10:30pm MT. Reviews will not pull in during this time, nor will users be able to respond to reviews or credit users to reviews.