All systems operational

Scheduled Maintenance

Completed
Scheduled for October 29, 2022 at 4:00 AM – 5:00 AM

Affects

Reviews
Webchat
Updates
  • Completed
    October 29, 2022 at 5:00 AM
    Completed
    October 29, 2022 at 5:00 AM

    Maintenance has completed successfully

  • In progress
    October 29, 2022 at 4:00 AM
    In progress
    October 29, 2022 at 4:00 AM

    Maintenance is now in progress

  • Planned
    October 29, 2022 at 4:00 AM
    Planned
    October 29, 2022 at 4:00 AM

    There will be maintenance on our Reviews and Webchat platforms on Friday, October 28th, from 10:00pm to 11:00pm MT. Users will not be able to send review invites during this time, and Webchat settings will not be editable from within Podium. Web Suite will continue to function.