Resolved
"Deposits and Withdrawals" Payments reporting page failing to load

Started
November 28, 2022 at 8:37 PM
Status
Resolved after 29 minutes

Impact

Degraded performance
Affected
Payments
  • Resolved
    November 28, 2022 at 9:06 PM

    We just resolved the issue!

  • Investigating
    November 28, 2022 at 8:37 PM

    We are currently investigating this incident.