Podium - Some users unable to access Payment Activity – Incident details

All systems operational

Some users unable to access Payment Activity

Resolved
Operational
Started over 1 year agoLasted 14 minutes

Affected

Payments

Operational from 7:22 PM to 7:36 PM

Updates
  • Resolved
    Resolved

    We just resolved the issue!

  • Identified
    Identified

    We have identified the cause of the issue and are continuing to work on a fix for this incident.

  • Investigating
    Investigating

    We are aware of an issue causing some users to not load the Payment Activity page. We are currently looking into this issue.