Podium - Unable to connect Google or respond to Google reviews, and reviews not pulling in – Incident details

Reviews experiencing degraded performance

Unable to connect Google or respond to Google reviews, and reviews not pulling in

Resolved
Operational
Started almost 2 years agoLasted about 2 hours

Affected

Reviews

Operational from 8:14 PM to 10:00 PM

Updates
  • Resolved
    Resolved

    This should be fixed now. Users should see Google reviews pull into Podium again, be able to respond to reviews, and be able to connect Google.

  • Update
    Update

    Users may also be seeing issues with Google reviews pulling into the platform. We are still working to get this up and running ASAP.

  • Identified
    Identified

    Users may be experiencing issues with both connecting Google to Podium, and with responding to Google reviews within Podium. We are working with Google to resolve this.