Podium - Payments Send Failure – Incident details

Reviews experiencing degraded performance

Payments Send Failure

Resolved
Degraded performance
Started almost 2 years agoLasted 13 minutes

Affected

Payments

Degraded performance from 3:52 PM to 4:05 PM

Updates
  • Resolved
    Resolved

    This has been resolved! Thanks for your patience.

  • Investigating
    Investigating

    We are aware of an issue preventing payments from sending successfully. We are currently investigating this incident.