Podium - Help Center site is down – Incident details

Messaging experiencing degraded performance

Help Center site is down

Resolved
Operational
Started about 1 year agoLasted about 4 hours

Affected

Podium Services

Operational from 4:30 PM to 8:33 PM

Updates
  • Resolved
    Resolved

    This issue should be resolved

  • Monitoring
    Monitoring

    We've implemented a fix. New visitors should be able to view the site while recent visitors may need to wait a few more minutes for the fix to take place. We'll continue to monitor until we've ensured all users are able to access the site.

  • Investigating
    Investigating

    We're currently investigating our help center page at help.podium.com as it appears to be down for most users. We'll provide updates soon.