Podium - Some users cannot make or receive calls on deskphones or add new deskphones to locations – Incident details

Reviews experiencing degraded performance

Some users cannot make or receive calls on deskphones or add new deskphones to locations

Resolved
Partial outage
Started 6 months agoLasted about 20 hours

Affected

Phones

Partial outage from 7:44 PM to 9:15 PM, Degraded performance from 9:15 PM to 4:00 AM, Operational from 4:00 AM to 3:18 PM

Updates
  • Resolved
    Resolved

    We have fully recovered. If you are still experiencing issues, please contact Podium Support.

  • Monitoring
    Update

    We're continuing to see signs of full recovery. We are still monitoring closely. If you are still experiencing issues, please contact Podium Support.

  • Monitoring
    Update

    We're seeing signs of full recovery. We will continue to monitor until traffic has been confirmed to be at normal operational levels.

  • Monitoring
    Update

    New devices can be added to accounts now. Users may see issues with the below still:

    • Delays on outbound calls

    • Intermittent failures of using the webphone to control deskphones for outbound calls

  • Monitoring
    Update

    We are seeing intermittent slowness with outbound calls and adding new devices to accounts is still not working.

  • Monitoring
    Monitoring

    We're seeing improvements with inbound and outbound traffic and returning to normal levels. We will continue to monitor until full recovery.

  • Identified
    Update

    We're continuing to work with our third-party for resolution. While we are seeing improvements, users may see issues with the below:

    • Inbound and outbound calls on desk phones are intermittently having issues

    • Phones-related Settings changes made are intermittently not taking effect

    • Adding a desk phone is intermittently not working

  • Identified
    Identified

    We have identified an issue with a third-party that is causing issues with some outbound and inbound calls. We're working with that provider for resolution.

  • Investigating
    Investigating
    We are currently investigating this incident.