Scheduled for June 02, 2024 at 4:00 AM – 4:10 AMUTC
Affects
Phones
Under maintenance from 4:00 AM to 4:10 AM
Updates
Completed
June 02, 2024 at 4:10 AMUTC
Completed
June 02, 2024 at 4:10 AMUTC
Maintenance has completed successfully
In progress
June 02, 2024 at 4:00 AMUTC
In progress
June 02, 2024 at 4:00 AMUTC
Maintenance is now in progress
Planned
June 02, 2024 at 4:00 AMUTC
Planned
June 02, 2024 at 4:00 AMUTC
We are performing scheduled maintenance on our Phones Product June 1st, 2024 at 10:00 PM MT. There may be a brief window where inbound and outbound calling and other Phone features may not be available.