Podium - Email leads delayed – Incident details

All systems operational

Email leads delayed

Resolved
Degraded performance
Started 26 days agoLasted about 24 hours

Affected

LeadDrive

Degraded performance from 3:59 PM to 3:41 PM

Updates
  • Resolved
    Resolved

    This issue has been resolved.

  • Identified
    Identified

    Gmail leads are back up, but Outlook is still down due to an outage on Microsoft's end. We're continuing to monitor this and will get it back up and running in Podium as soon as we're able to.

  • Investigating
    Investigating

    We are currently seeing an issue where some leads from email sources are delayed in pulling into Podium. We are working on a fix.