Podium - Changes to the desk phone settings page is currently not working – Incident details

All systems operational

Changes to the desk phone settings page is currently not working

Resolved
Degraded performance
Started 2 days agoLasted about 24 hours

Affected

Phones

Degraded performance from 7:31 PM to 7:19 PM

Updates
  • Resolved
    Resolved

    We have implemented a fix and the incident has been resolved. Thank you for your patience!

  • Investigating
    Investigating

    Currently any changes made to the desk phones settings page are not saving. Also accounts are unable to add new users. We are currently looking into this issue and will provide an update shortly.