Scheduled for April 13, 2025 at 9:00 AM – 10:00 AM
Affects
Web Application
Under maintenance from 9:00 AM to 10:00 AM
Completed
April 13, 2025 at 10:00 AMCompleted
April 13, 2025 at 10:00 AMMaintenance has completed successfully
In progress
April 13, 2025 at 9:00 AMIn progress
April 13, 2025 at 9:00 AMMaintenance is now in progress
Planned
April 13, 2025 at 9:00 AMPlanned
April 13, 2025 at 9:00 AMWe are planning for a scheduled maintenance on April 13th at 3:00am MT. You may see an increase in errors during this time that should be resolvable with a retry.