Podium - Some Outlook emails not delivering – Incident details

All systems operational

Some Outlook emails not delivering

Resolved
Degraded performance
Started 14 days agoLasted about 5 hours

Affected

LeadDrive

Degraded performance from 7:49 PM to 12:48 AM

Updates
  • Resolved
    Resolved

    This issue is resolved 🎉

  • Update
    Update

    We're seeing a spike in Outlook emails failing, but are communicating with Outlook and continuing to work on it.

  • Monitoring
    Monitoring
    We've seen a small amount of both inbound and outbound Outlook emails not send successfully. We have a fix in place and are monitoring the issue.