Scheduled for January 18, 2026 at 10:00 AM – 10:30 AM
Affects
Web Application
Under maintenance from 10:00 AM to 10:30 AM
Updates
Completed
January 18, 2026 at 10:30 AM
Completed
January 18, 2026 at 10:30 AM
Maintenance has completed successfully
In progress
January 18, 2026 at 10:00 AM
In progress
January 18, 2026 at 10:00 AM
Maintenance is now in progress
Planned
January 18, 2026 at 10:00 AM
Planned
January 18, 2026 at 10:00 AM
We will have some scheduled maintenance on January 18th at 3am Mountain Time. Maintenance should last about 30 minutes. Podium may be down during this time