Podium - Android users unable to log into Podium app – Incident details

Mobile experiencing degraded performance

Android users unable to log into Podium app

Monitoring
Degraded performance
Started 3 days ago

Affected

Mobile

Degraded performance from 3:39 PM to 12:00 AM

Updates
  • Monitoring
    Monitoring

    We've pushed out the app version, 2026.10.0, that contains the fix for this issue and are currently waiting for the Google Play Store to finish their review. This can take a number of hours but we'll update this incident once the update is widely available

  • Identified
    Identified

    We've identified the issue affecting users who can't log into Podium using the Android app. We're working on pushing a new version with the fix to the Google Play Store as soon as possible.

    In the meantime, users are still able to log into the app using a one-time password (by going through the "Forgot Password" flow) or by signing in using Google or Apple sign-in options

  • Investigating
    Investigating
    We're seeing users unable to log into the Podium app on Android devices by using their password. If you're running into this issue, going through the "Forgot Password" flow and requesting a One-Time Password is still functional