Podium - Payment Creation form not appearing from the conversation button – Incident details

All systems operational

Payment Creation form not appearing from the conversation button

Resolved
Operational
Started almost 2 years agoLasted 8 minutes

Affected

Payments

Operational from 6:54 PM to 7:03 PM

Updates
  • Resolved
    Resolved

    We have resolved the issue involving Payments Creation forms. Thank you for your patience!

  • Investigating
    Investigating

    We are currently investigating this incident. In the meantime, using the (+) button in the navigation bar on desktop will still show the Payment Creation form.