All systems operational

Payments Creation issues on Android app

Resolved
Operational
Started 10 months ago Lasted about 2 hours

Affected

Mobile
Payments
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    We are implementing a fix and are currently monitoring the result.

  • Investigating
    Investigating

    We are aware of an issue preventing some users from creating payment requests on the Android app. As a workaround, Android users can log into the web version of Podium on web app such as Chrome or Safari to send payment requests. We are currently investigating this incident, updates to come.