Experiencing partially degraded performance

Some users unable to load Inbox page; seeing "uh-oh" error

Resolved
Degraded performance
Started 13 days ago Lasted about 1 hour

Affected

Messaging
Web Application
Updates
  • Resolved
    Resolved

    This issue has been resolved.

  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating

    We are currently investigating this incident.