Experiencing partially degraded performance

Changes made to contacts are not saving

Resolved
Operational
Started 13 days ago Lasted about 2 hours

Affected

Contacts
Updates
  • Resolved
    Resolved

    We have seen our error rates return to normal for a while now. We're resolving this incident and work on improving our processes.

  • Monitoring
    Monitoring

    We've seen changes being saved again. The root cause hasn't been discovered yet and we'll continue investigating to ensure contacts continue to stay healthy.

  • Investigating
    Investigating

    Any changes to names, numbers, or events for contacts are currently not being saved. We've got our engineering team taking a look now. We'll provide an update shortly