Podium - Contacts Page and Contact Drawers slow to load or not loading at all – Incident details
All systems operational
Contacts Page and Contact Drawers slow to load or not loading at all
Resolved
Degraded performance
Started 5 months agoLasted 17 minutes
Affected
Contacts
Degraded performance from 9:19 PM to 9:36 PM
Updates
Resolved
Resolved
This issue has been identified and resolved.
Investigating
Investigating
Some customers are seeing slowness to load in their Contacts page and Contact drawer to the right of their conversations, with occasional failures to load. We are currently investigating this incident.