Podium - We are currently seeing an issue with New phones being added to the account. – Incident details

All systems operational

We are currently seeing an issue with New phones being added to the account.

Resolved
Degraded performance
Started about 21 hours agoLasted about 21 hours

Affected

Phones

Degraded performance from 8:17 PM to 5:36 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Currently new phones cannot be added to the account and we are looking into the issue right now.