Podium - Help Site is Unreachable – Incident details

All systems operational

Help Site is Unreachable

Resolved
Degraded performance
Started 3 days agoLasted 31 minutes

Affected

Web Application

Operational from 4:56 PM to 5:27 PM

Updates
  • Resolved
    Resolved

    We've returned access to help.podium.com. We appreciate the patience while we resolved this issue

  • Investigating
    Investigating
    Our help website help.podium.com is currently showing an error message. We've got our team taking a look and will provide an update as soon as possible