Podium - Contacts page giving "Uh-Oh" error – Incident details

All systems operational

Contacts page giving "Uh-Oh" error

Resolved
Degraded performance
Started 10 days agoLasted about 1 hour

Affected

Contacts

Degraded performance from 4:55 PM to 5:30 PM, Operational from 5:30 PM to 5:58 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We have implemented a fix and are monitoring the result as we continue to monitor the AWS incident.

  • Investigating
    Investigating
    Our contacts page has been affected by a large AWS outage and may give users an "uh-oh" error when visiting the page. We are monitoring the AWS outage and doing everything we can in the meantime to mitigate this issue.