Podium - Some Podium Phones are down – Incident details
All systems operational
Some Podium Phones are down
Resolved
Partial outage 60 %
Started 3 days agoJuly 21, 2026Lasted 9 minutesJuly 21, 20268:348:43 PMUTC
Affected
Phones
Partial outage from 8:34 PM to 8:39 PM, Operational from 8:39 PM to 8:43 PM
Updates
Resolved
UTC
Resolved
UTC
Our Podium Phones functionality has fully returned to normal. We apologize for the inconvenience this caused and will be investigating the root cause to ensure similar down time doesn't occur again.
Monitoring
UTC
Monitoring
UTC
We've implemented our fix and are seeing results return to normal. We're continuing to monitor to ensure regular functionality
Investigating
UTC
Investigating
UTC
We're seeing a large number of internal errors with Podium Phones causing calls to fail. We're actively investigating and working on a fix to resolve these errors and will provide an update soon