All systems operational

Some Podium users getting a blank page on login

Resolved
Degraded performance
Started over 1 year ago Lasted 36 minutes

Affected

Web Application
Updates
  • Resolved
    Resolved

    This issue has been resolved.

  • Monitoring
    Monitoring

    We have pushed a fix for this issue; the platform should be loading correctly for all users. We are monitoring to catch any additional irregularities.

  • Investigating
    Investigating

    Some Podium users are getting a blank page when trying to load the inbox. We are currently investigating this incident.

    If you are seeing this issue, refreshing your page or selecting a different tab may allow you to access the site.