Experiencing partially degraded performance

Conversation items from calls are delayed from showing up in the Podium Inbox

Resolved
Degraded performance
Started 2 months ago Lasted about 1 hour

Affected

Phones
Updates
  • Resolved
    Resolved

    Delayed conversation items are starting to load within Podium Inbox now and should be fully loaded within 10 minutes. Conversation items for Phones(e.g., Missed calls, In Progress calls) should be back up and running.

  • Investigating
    Investigating
    We are currently investigating this incident.