Messaging experiencing degraded performance

Text message delivery delays and failures to T-Mobile Network in the US

Resolved
Degraded performance
Started 17 days ago Lasted about 2 hours

Affected

Messaging
Updates
  • Resolved
    Resolved

    We have confirmed messages are no longer delayed or failing when sent to the T-mobile network.

  • Monitoring
    Monitoring

    We are no longer seeing delivery failures when sending to T-mobile. We will continue to monitor until we have a confirmed resolution from our carrier partner.

  • Identified
    Identified

    We're continuing to see some messages delayed as well as timing out when sending to T-mobile. We are still working with our carrier partner and will provide updates as we receive them.

  • Investigating
    Investigating

    We are seeing issues with our partners and the T-Mobile network in the US that are causing SMS and MMS delays. We're working with our partners to get the latest information and will provide updates as we receive them