All systems operational

[Resolved] Payments Failing to Load on Android App

Started on June 3, 2021 at 4:59 PM. Resolved after about 3 hours

Affected

Mobile
Payments
  • Investigating
    June 3, 2021 at 4:59 PM

    We are currently investigating this incident.

    Users may be seeing:

    • A blank page with a “Something went wrong” error
    • Clicking the payments icon/composer app does nothing
  • Investigating
    June 3, 2021 at 5:16 PM

    Update: Some iOS devices may be impacted along with Android.

  • Investigating
    June 3, 2021 at 5:43 PM

    We're still investigating the issue, and we'll provide an update soon.

  • Resolved
    June 3, 2021 at 7:45 PM

    We implemented a fix and currently monitoring the result. Generating invoices should work on Android and iOS.