All systems operational

[Resolved] Issues Adding & Editing Users

Started on June 14, 2021 at 5:20 PM. Resolved after 12 minutes

Affected

Web Application
  • Investigating
    June 14, 2021 at 5:20 PM

    We are currently investigating this incident. Some accounts may be unable to add or edit users in Podium.

  • Resolved
    June 14, 2021 at 5:32 PM

    Only a very small set of accounts were affected. We'll be monitoring this to make sure no other accounts are affected.