All systems operational

[Resolved] Login -Desktop

Started on June 29, 2021 at 9:08 PM. Resolved after 17 minutes

Affected

Web Application
  • Investigating
    June 29, 2021 at 9:08 PM

    We are currently investigating reports of users unable to login on the Podium desktop.

  • Resolved
    June 29, 2021 at 9:24 PM

    We just resolved the issue!