All systems operational

[Resolved] Some users may see issues initiating Secure Messaging

Started on October 14, 2021 at 9:52 PM. Resolved after about 2 hours

Affected

Messaging
  • Investigating
    October 14, 2021 at 9:52 PM

    We are currently investigating this incident.

  • Identified
    October 14, 2021 at 10:46 PM

    We are continuing to work on a fix for this incident.

  • Resolved
    October 14, 2021 at 11:34 PM

    We just resolved the issue!