All systems operational

Users experiencing errors accessing Podium

Resolved
Operational
Started 28 days ago Lasted about 1 hour

Affected

Bulk Messaging
Payments
Web Application
Updates
  • Resolved
    Resolved

    We've resolved the issue with our platform, Podium Payments, and Bulk Messaging. We appreciate your patience with us.

  • Investigating
    Update

    We've implemented a potential fix to the issue and have started to see users able to access the site again. We'll continue to monitor to ensure that no further errors appear.

    Podium Payments and Bulk Messages might still be seeing issues, we're continuing to work on this.

  • Investigating
    Update

    We appreciate the patience as our engineering team continues to dig into the issue. We're still working on identifying what is the root cause of these errors.

  • Investigating
    Investigating

    Most users are running into an "Uh-oh" error page when attempting to use Podium. We've got our engineering team on this and hope to be back up as soon as possible. We'll provide updates shortly.