Podium - Intermittent call failures on inbound and outbound calls and some completed calls displaying as in progress – Incident details

All systems operational

Intermittent call failures on inbound and outbound calls and some completed calls displaying as in progress

Resolved
Operational
Started 4 months agoLasted about 5 hours

Affected

Phones

Degraded performance from 4:02 PM to 6:03 PM, Operational from 6:03 PM to 9:22 PM

Updates
  • Resolved
    Update

    We have confirmed this issue is completely resolved.

  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified

    We are encountering several issues with our phone system:

    1. Inbound calls:

      • Some inbound calls are failing intermittently.

      • The failing calls say the message "An application error occurred".

    2. Outbound calls:

      • Certain outbound calls are failing.

      • The failing outbound calls say the message "An application error occurred" before disconnecting.

      • When a successful outbound call is made, but the recipient hangs up, the calling phone does not end the call immediately. Instead, it displays "An application error occurred" and then drops the call.

        • When this occurs, completed calls in the Podium inbox display incorrectly with an "In Progress" status.