Podium - Some users are unable to update passwords – Incident details

All systems operational

Some users are unable to update passwords

Resolved
Operational
Started 3 months agoLasted 15 minutes

Affected

Web Application

Degraded performance from 3:34 PM to 3:49 PM

AI Employee

Operational from 3:34 PM to 3:49 PM

Updates
  • Resolved
    Resolved

    We have resolved this issue. Thank you for your patience!

  • Investigating
    Investigating

    Users are unable to update password by going through the Forgot Password flow. We've got our engineering team working on fixing this issue and will provide an update shortly