Podium - Payments Report Download missing – Incident details

All systems operational

Payments Report Download missing

Resolved
Degraded performance
Started about 2 months agoLasted about 3 hours

Affected

Payments

Degraded performance from 2:12 PM to 5:22 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We have identified the issue and we are working on implementing a fix.

  • Investigating
    Investigating

    We are aware of an issue with the option to download reports of payment activity missing from the Payments dashboard. We are currently investigating the issue and will update as soon as more information is available.