Podium - The Users page is showing no results for some orgs – Incident details

All systems operational

The Users page is showing no results for some orgs

Resolved
Degraded performance
Started 3 months agoLasted 17 minutes

Affected

Web Application
Updates
  • Resolved
    Resolved

    We have resolving this issue. A refresh should fix the issue if you are still experiencing it. Thank you!

  • Identified
    Identified

    We believe we've identified the cause of the issue. We're actively working on a fix.

    A simple workaround in the meantime is clicking the Location Picker in the upper-right corner of the page and selecting a location.

  • Investigating
    Investigating

    Some orgs are unable to see any users on the Users page. We're currently having our engineering team take a look into this.