Podium - Possible delays with Emails – Incident details

All systems operational

Possible delays with Emails

Resolved
Degraded performance
Started 1 day agoLasted about 18 hours

Affected

Messaging

Degraded performance from 10:05 PM to 3:52 PM

Updates
  • Resolved
    Resolved

    Email delivery rates have returned to normal. Thank you for your patience

  • Monitoring
    Monitoring

    We've seen delays start to return to normal. We'll continue to monitor this issue to ensure delivery times continue to stabilize

  • Investigating
    Investigating

    We're seeing delays with email outbound messages due to our partners. We'll monitor and continue to provide updates as we receive them.