Resolved
Unable to Send Payment Request via Android Device

Started
April 27, 2022 at 6:48 PM
Status
Resolved after 12 minutes
Affected
Mobile
Payments

Impact

Degraded performance
  • Resolved
    April 27, 2022 at 7:00 PM

    We identified and resolved the issue!

  • Investigating
    April 27, 2022 at 6:48 PM

    We are currently investigating this incident.