Resolved
Difficulties creating a payment invoice

Started
June 20, 2022 at 3:49 PM
Status
Resolved after 4 minutes
Affected
Payments

Impact

Operational
  • Monitoring
    June 20, 2022 at 4:03 PM

    We implemented a fix and currently monitoring the result to ensure it has resolved the issue.

  • Identified
    June 20, 2022 at 3:53 PM

    We believe we have identified the issue and are working on a resolution.

  • Resolved
    June 20, 2022 at 3:53 PM

    We believe we have identified the issue and are working on a resolution.

  • Investigating
    June 20, 2022 at 3:49 PM

    We are currently investigating this reported issue. We will update here shortly.