Podium - User Invites are not working – Incident details

All systems operational

User Invites are not working

Resolved
Degraded performance
Started 2 months agoLasted 26 minutes

Affected

Podium Services

Degraded performance from 8:22 PM to 8:48 PM

Updates
  • Resolved
    Resolved

    We have resolved the issue with user invitations. We value your patience while we were resolving this issue.

  • Identified
    Identified

    We've identified what the issue is with user invites and are working on implementing a fix

  • Investigating
    Investigating

    Invitations to add new users to your account are currently not working. We've got our engineering team taking a look and we'll provide updates soon.