Podium - Some users are seeing an issue with caller ID not displaying on desk phones – Incident details

Messaging experiencing degraded performance

Some users are seeing an issue with caller ID not displaying on desk phones

Resolved
Operational
Started 4 days agoLasted 2 days

Affected

Phones

Operational from 8:07 PM to 4:30 PM

Updates
  • Resolved
    Resolved

    Thank you for your patience with this incident

  • Monitoring
    Monitoring

    We've identified the issue and are working with our partner to help resolve this as quickly as possible. We'll provide an update once we've resolved the issue

  • Investigating
    Investigating

    We are currently investigating this incident. This issue does not affect our web phones, only desk phones.